The intermittant issues have been fixed.

Incident Report for Dagster Cloud

Resolved

This issue has now been resolved.
Posted Jun 27, 2025 - 18:58 UTC

Monitoring

We observed some API latency and errors from 2:15pm-2:45pm EST. We've identified the issue and have released a fix.
Posted Jun 27, 2025 - 18:56 UTC