Some users cannot access catalog UI

Incident Report for Dagster Cloud

Resolved

This incident has been resolved.
Posted 9 days ago. Mar 27, 2025 - 14:21 UTC

Monitoring

A fix was deployed and we are monitoring the situation.
Posted 9 days ago. Mar 27, 2025 - 12:24 UTC

Identified

Issue was identified and a fix is currently being worked on.
Posted 9 days ago. Mar 27, 2025 - 11:53 UTC

Investigating

We detected errors for some users when accessing the catalog Dagster+ UI. Using incognito mode in the browser solves it. We are currently investigating the problem to provide fast mitigation.
Posted 9 days ago. Mar 27, 2025 - 10:51 UTC
This incident affected: Dagster Cloud UI.