dagster.plus redirect breaks login for some organizations
Incident Report for Dagster Cloud
Resolved
In anticipation of today's Dagster+ launch event, we added a second domain to our app: dagster.plus. Last night, we erroneously started redirecting certain requests from dagster.cloud to dagster.plus.

As a result, organizations who explicitly allow-list dagster.cloud in their corporate firewalls saw redirected requests to dagster.plus fail.

Affected requests included:
- Interactive use of the Dagster web interface
- GraphQL queries authenticated with a user token (for example, many CI/CD jobs)

Agent interactions (including launching runs and storing events) were not redirected and continued to operate as expected.

Organizations without these firewall settings were not affected.

Once detected, we began working on a way to selectively disable redirects for affected organizations. Shortly after, we removed redirects entirely for all organizations.

However, many browsers permanently cache redirects. If you continue to have trouble accessing dagster.cloud please clear your browser cache and try again.

Internally, we're conducting a full postmortem and deciding how to more safely introduce our new domain name in the future.
Posted Apr 17, 2024 - 13:53 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 17, 2024 - 13:53 UTC
Identified
In preparation for our Dagster+ launch, we erroneously began redirecting dagster.cloud to dagster.plus. We are rolling back this change now.

If you continue to have trouble logging in, you may need to clear your browser's cache.
Posted Apr 17, 2024 - 13:20 UTC
This incident affected: API and Dagster Cloud UI.